#vDM30in30,  #vExpert

VCSA 6.5 A problem occurred while reading the OVF file / Error: ovftool is not available on Mac

So today I spent sometime updating and rebuilding my lab so I could write some further articles. It appears one of the versions that you may well have downloaded of the VCSA ISO has a small bug. My version of the ISO was called VMware-VCSA-all-6.5.0-4602587.iso but it may well have been fixed now otherwise you get the following error whilst trying to install the VCSA appliance from the Mac GUI.

A problem occurred while reading the OVF file.: Error: ovftool is not available

screen-shot-2016-11-20-at-21-38-56

I must say a massive thanks to David Stamen on the vExpert Slack for finding a fix for this and pointing me in the right direction. I believe Emad Younis is also aware of the issue and will be looking into this. I did see his post about it only hitting macOS Sierra 10.12.1 but I am still on 10.12 (10.12 Beta (16A312a)) and I still get the error. I thought another person putting something up about it would be good as I got nothing from Google at the time of writing this article.

It appears to be down to how the OS now prepares certain things. I didn’t have time to test this on my older Mac as the workaround is fairly easy anyway. Much better than me scrabbling round and installing the OVF tool and scratching my head wondering why it still doesn’t work.

The trick is to save the error log from the above window and herein lies the answer to getting it to work. Again I haven’t got another machine at this OS level to test so I am making an assumption that the path may differ in each persons profile and/or machine.

If you scroll to the end of the log you will see a very interesting path. Copy this out and open the location from Go to folder… action from within finder (CMD+Shift+G).

screen-shot-2016-11-20-at-21-46-09

Inside this folder copy the whole VCSA folder from the ISO and relaunch the VCSA GUI. It did find you could select back and next and it would work but better to be safe. You will now see that this can read the OVF and all the items get populated as expected. I have also been advised to copy out the whole ISO to a temporary folder and run the GUI from here to get best results.

screen-shot-2016-11-20-at-21-50-19

 

5 Comments

  • Shahnawaz

    i have gone through the logs but unable to find the path in logs, here i have pasted the logs,

    2017-12-26T20:29:15.676Z – info: LogLevel: debug
    2017-12-26T20:29:15.746Z – info: Underlying platform for the OS is: win32
    2017-12-26T20:29:15.746Z – info: Number of cpus is: 1
    2017-12-26T20:29:15.746Z – info: Speed of cpus is: 2594
    2017-12-26T20:29:15.750Z – info: RAM is: 2 GB
    2017-12-26T20:29:15.752Z – debug: wizardTitle: {WORKFLOW_NAME} – Stage 1: Deploy appliance
    2017-12-26T20:29:19.382Z – debug: wizardTitle: Install – Stage 1: Deploy appliance
    2017-12-26T20:29:19.403Z – info: Feature switch VUMUpgradeEnabled: true
    2017-12-26T20:29:36.570Z – debug: eulaTxtUrl: eula_en.html
    2017-12-26T20:29:39.711Z – debug: wizardTitle: Install – Stage 1: Deploy appliance
    2017-12-26T20:30:07.556Z – debug: nodeType: embedded
    2017-12-26T20:30:07.556Z – debug: wizardTitle: Install – Stage 1: Deploy vCenter Server with an Embedded Platform Services Controller
    2017-12-26T20:30:21.824Z – debug: Target IP address in DOM input value is: 192.168.1.145
    2017-12-26T20:30:21.824Z – debug: Target IP Value in data model is: 192.168.1.145
    2017-12-26T20:30:21.824Z – debug: Target IP Value in data model after correction is: 192.168.1.145
    2017-12-26T20:30:31.794Z – debug: Target IP address in DOM input value is: 192.168.1.145
    2017-12-26T20:30:31.794Z – debug: Target IP Value in data model is: 192.168.1.145
    2017-12-26T20:30:31.794Z – debug: Target IP Value in data model after correction is: 192.168.1.145
    2017-12-26T20:31:00.004Z – debug: ip address in data model on leaving page is: 192.168.1.145
    2017-12-26T20:31:02.165Z – error: Could not get certificate fingerprint from host, 192.168.1.145: Error: connect ECONNREFUSED 192.168.1.145:443

    Actually the logs are not generatin, last updates is 26th Dec and i am working today as well.

    Can u pls help me to find the logs

  • Shahnawaz

    please let me know from below logs where i should paste the contents of VSCA iso contents, below are the logs,

    2017-12-29T00:10:35.843Z – info: ESXi hostCheck was successful
    2017-12-29T00:10:50.142Z – info: vmName: VMware vCenter Server Appliance
    2017-12-29T00:10:50.212Z – debug: token:undefined, length:1, running total:1
    2017-12-29T00:10:50.212Z – info: number of vms with name, VMware vCenter Server Appliance: 0
    2017-12-29T00:10:50.249Z – debug: Deployment size page description: Select the deployment size for this vCenter Server with an Embedded Platform Services Controller.
    2017-12-29T00:10:50.250Z – debug: scope.backupProfileDataArr: undefined
    2017-12-29T00:10:50.252Z – info: ovftoolCmd: C:\Windows\Temp\vcsa\ovftool\win32\ovftool.exe
    2017-12-29T00:10:50.252Z – debug: ovaFileNameRe: /^VMware-vCenter-Server-Appliance-.*_OVF10.ova$/
    2017-12-29T00:10:50.253Z – debug: files in C:\Windows\Temp\vcsa: ovftool,version.txt,VMware-vCenter-Server-Appliance-6.5.0.5100-7070488_OVF10.ova
    2017-12-29T00:10:50.254Z – info: ovaFile: C:\Windows\Temp\vcsa\VMware-vCenter-Server-Appliance-6.5.0.5100-7070488_OVF10.ova
    2017-12-29T00:10:50.419Z – info: probeOvf exited with status null
    2017-12-29T00:10:50.436Z – error: probeOvf null status, signal: null, error: { Error: spawnSync C:\Windows\Temp\vcsa\ovftool\win32\ovftool.exe UNKNOWN
    at exports._errnoException (util.js:1008:11)
    at spawnSync (child_process.js:465:20)
    at Object.probeOvf (file:///C:/Windows/Temp/vcsa-ui-installer/win32/resources/app/services/ovfProbeService.js:60:28)
    at getProfileLayoutData (file:///C:/Windows/Temp/vcsa-ui-installer/win32/resources/app/controllers/selectSizeController.js:182:45)
    at new (file:///C:/Windows/Temp/vcsa-ui-installer/win32/resources/app/controllers/selectSizeController.js:683:7)
    at Object.invoke (file:///C:/Windows/Temp/vcsa-ui-installer/win32/resources/app/bower_components/angular/angular.js:4560:17)
    at extend.instance (file:///C:/Windows/Temp/vcsa-ui-installer/win32/resources/app/bower_components/angular/angular.js:9425:34)
    at nodeLinkFn (file:///C:/Windows/Temp/vcsa-ui-installer/win32/resources/app/bower_components/angular/angular.js:8530:34)
    at compositeLinkFn (file:///C:/Windows/Temp/vcsa-ui-installer/win32/resources/app/bower_components/angular/angular.js:7965:13)
    at publicLinkFn (file:///C:/Windows/Temp/vcsa-ui-installer/win32/resources/app/bower_components/angular/angular.js:7845:30)
    code: ‘UNKNOWN’,
    errno: ‘UNKNOWN’,
    syscall: ‘spawnSync C:\\Windows\\Temp\\vcsa\\ovftool\\win32\\ovftool.exe’,
    path: ‘C:\\Windows\\Temp\\vcsa\\ovftool\\win32\\ovftool.exe’,
    spawnargs:
    [ ‘–machineOutput’,
    ‘–sourceType=ova’,
    ‘C:\\Windows\\Temp\\vcsa\\VMware-vCenter-Server-Appliance-6.5.0.5100-7070488_OVF10.ova’ ] }
    2017-12-29T00:10:50.438Z – error: OVF probe error: Error: ovftool exited unexpectedly

Leave a Reply to Shahnawaz Cancel reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.