If any of you have read my vDM challenge 1 post you will know that I wanted to create a mini mobile data center on wheels but the twist was I wanted this to be an electric/hybrid vehicle. I also would love my lab to be mobile so I can take this to clients and the fact if I am challenged on this during my defense this evening I can say it works!

My criteria was to start

  • My lab can run on a single car inverter
  • It should ideally be the size of a shoe box or flight case
  • The vehicle in use is a hybrid or full electric
  • Internet was accessible
  • VMware at least started!

Whilst conceptual I thought well could or should this work. Only one way to find out I thought, it was a good time to put theory into practice. I know I may have bored a few VMUG people with this idea but low and behold it pretty much worked. I could not test this 100% as unfortunately I don’t have access to a 2nd Meraki MX or Z1 at the moment and my VSAN decided to collapse of which it has never done before. I only know this as I have moved my lab enough times in the last few weeks and its been fine just this time it said no more!

First things first we needed to get a Ethernet connection in the car let alone an internet connection. I could have achieved this in multiple ways but due my my car of choice being the Audi A3 E-Tron I already have WiFi on board I just needed to get this to Ethernet. The reason for me personally choosing an E-Tron is the battery capacity is more than enough to get me to work, I have charging points at my office and where I do have a petrol engine I am not limited to range in theory. I am a glorified generator on wheels. Its also quite fun to drive as the power is just there and if you put your foot down you are in for a right surprise. Either way I have digressed so back to getting Ethernet to my firewall. I came across a very nice guide by Chris Harvey that allowed me to utilize my old Sky connector of which was just sat in a drawer gathering dust since going to fixed connections in the house.

Overall I manged to follow his guide but to get access to the configuration page and IP I found it much easier to hit the WPS button and the box then started broadcast to help me capture this easier. If you do have a WPS router if you connect it to this first you will easily spots its 169 address swap to your local subnet

Now to try this out in the car… At first I thought yeah this will work but lets try my laptop first before I pull my whole lab out. Within 2 minutes of associating the AP with the car I was browsing the web quite happily via my Ethernet port.

wifi2wifi1

So now the real test that happened a few days later as I wanted to ensure I got the WAF before taking down the house Internet…. The first test was just the Meraki and again within minutes it was online and showing in the Meraki dashboard.

meraki1meraki2

Now to roll out the full test, yes I know this doesnt look amazing neat but where it is working conceptually I want to go back to getting a flight case to put all this in so I could take it to clients too

nucs1nucs2

As you can see everything seemed to come up but the VSAN. I am still investigating this and a further blog post will follow but overall I am very pleased as in theory I have a hybrid hybrid  datacenter on wheels of which I can charge its 8,8KWH battery by driving it about or finding one of the many free sockets I could then run my DR plan for just the cost of getting there and my data!

 

What I want to do next:-

  • Stop the PSUs for the NUCs buzzing when on the car inverter
  • Get my All Flash VSAN working again
  • Do some performance tests in the car with the above and PernixData
  • Get my Citrix Lab running on here again and dialing in remotely
  • Create a Mearki site to site link back to the rest of my home lab
  • Get someone to test functionality whilst I am driving